Back to overview
Maintenance
SSL Certificate Update
Jun 28, 2026 at 5:20pm UTC
–
Jun 28, 2026 at 5:23pm UTC
Affected services
ihintelligence.ch
Resolved
Jun 28, 2026 at 5:23pm UTC
Maintenance ended
Affected services
Created
Jun 28, 2026 at 5:20pm UTC
We are switching providers for our SSL certificate meaning the site will be offline for atleast 1 hour, it is unclear when it will return
Affected services